Bug 116818

Summary: Tighten FontGlyphs interfaces to take FontDescription instead of Font
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: TextAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, kling, mitz
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch kling: review+

Description Antti Koivisto 2013-05-27 03:36:58 PDT
Tighten typing.
Comment 1 Antti Koivisto 2013-05-27 03:47:47 PDT
Created attachment 202963 [details]
patch
Comment 2 WebKit Commit Bot 2013-05-27 03:48:59 PDT
Attachment 202963 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/WebCore.exp.in', u'Source/WebCore/platform/graphics/Font.h', u'Source/WebCore/platform/graphics/FontCache.cpp', u'Source/WebCore/platform/graphics/FontCache.h', u'Source/WebCore/platform/graphics/FontFallbackList.cpp', u'Source/WebCore/platform/graphics/FontFallbackList.h', u'Source/WebCore/platform/graphics/blackberry/FontCacheBlackBerry.cpp', u'Source/WebCore/platform/graphics/freetype/FontCacheFreeType.cpp', u'Source/WebCore/platform/graphics/mac/FontCacheMac.mm', u'Source/WebCore/platform/graphics/qt/FontCacheQt.cpp', u'Source/WebCore/platform/graphics/win/FontCacheWin.cpp', u'Source/WebCore/platform/graphics/wince/FontCacheWinCE.cpp']" exit_code: 1
Source/WebCore/platform/graphics/FontFallbackList.h:74:  The parameter name "font" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 1 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2013-05-27 03:55:50 PDT
Comment on attachment 202963 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=202963&action=review

> Source/WebCore/ChangeLog:8
> +        This gives better understanding of what the actual inputs are.

I like this change a lot.

> Source/WebCore/platform/graphics/FontFallbackList.h:107
> -    mutable unsigned m_pitch : 3; // Pitch
> +    mutable unsigned m_pitch : 3;

I think the "Pitch" here is to signify that the type of m_pitch is actually Pitch (the enum.)
Still pretty redundant, though.
Comment 4 Antti Koivisto 2013-05-27 04:05:47 PDT
http://trac.webkit.org/changeset/150747