Bug 116545

Summary: [BlackBerry] Compositor API change: Don't pass the unused "viewport" parameter
Product: WebKit Reporter: Jakob Petsovits <jpetsovits>
Component: WebKit BlackBerryAssignee: Jakob Petsovits <jpetsovits>
Status: RESOLVED FIXED    
Severity: Normal CC: anilsson, commit-queue, rwlbuis
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Jakob Petsovits 2013-05-21 08:56:43 PDT
The "viewport" parameter in WebPageCompositor::render() is an artifact of our port's historical development, both unused and unnecessary. We should get rid of it.
Also change the name of the "documentContents" parameter to the more descriptive "documentSrcRect".
Patch below.
Comment 1 Jakob Petsovits 2013-05-21 08:58:57 PDT
Created attachment 202437 [details]
Patch
Comment 2 Arvid Nilsson 2013-05-21 11:51:59 PDT
Comment on attachment 202437 [details]
Patch

LGTM, nice cleanup
Comment 3 Jakob Petsovits 2013-05-21 12:02:36 PDT
Created attachment 202455 [details]
Patch

Mike Fenton recently changed indentations, update patch to apply against current trunk.
Comment 4 Jakob Petsovits 2013-05-21 13:28:38 PDT
Created attachment 202465 [details]
Patch

Bug 116542 modifies a clashing hunk and with it (probably) not getting in, update the patch to apply against the state of the code without the other patch.
Comment 5 Rob Buis 2013-05-23 20:51:38 PDT
Comment on attachment 202465 [details]
Patch

Ok.
Comment 6 WebKit Commit Bot 2013-05-23 23:07:35 PDT
Comment on attachment 202465 [details]
Patch

Clearing flags on attachment: 202465

Committed r150625: <http://trac.webkit.org/changeset/150625>
Comment 7 WebKit Commit Bot 2013-05-23 23:07:37 PDT
All reviewed patches have been landed.  Closing bug.