Bug 115646

Summary: HashTraits<RefPtr<P> >::PeekType should be raw pointer for better performance
Product: WebKit Reporter: Mikhail Pozdnyakov <mikhail.pozdnyakov>
Component: Web Template FrameworkAssignee: Mikhail Pozdnyakov <mikhail.pozdnyakov>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, benjamin, buildbot, commit-queue, darin, rniwa, webkit-ews
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
WIP
webkit-ews: commit-queue-
WIP 2
buildbot: commit-queue-
WIP 3
none
patch none

Description Mikhail Pozdnyakov 2013-05-06 08:01:42 PDT
HashTraits<RefPtr<P> >::PeekType should be raw pointer so that we can obviate multiple
RefPtr copying when invoking HashMap::get() method (and when HashMap value type is RefPtr).
Comment 1 Mikhail Pozdnyakov 2013-05-06 08:04:51 PDT
Created attachment 200671 [details]
WIP

let's see what EWS tells.
Comment 2 Early Warning System Bot 2013-05-06 08:14:50 PDT
Comment on attachment 200671 [details]
WIP

Attachment 200671 [details] did not pass qt-ews (qt):
Output: http://webkit-queues.appspot.com/results/378166
Comment 3 Early Warning System Bot 2013-05-06 08:18:11 PDT
Comment on attachment 200671 [details]
WIP

Attachment 200671 [details] did not pass qt-wk2-ews (qt-wk2):
Output: http://webkit-queues.appspot.com/results/281086
Comment 4 Build Bot 2013-05-06 08:27:49 PDT
Comment on attachment 200671 [details]
WIP

Attachment 200671 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/278056
Comment 5 Build Bot 2013-05-06 08:34:55 PDT
Comment on attachment 200671 [details]
WIP

Attachment 200671 [details] did not pass win-ews (win):
Output: http://webkit-queues.appspot.com/results/284026
Comment 6 Build Bot 2013-05-06 08:50:10 PDT
Comment on attachment 200671 [details]
WIP

Attachment 200671 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/289035
Comment 7 Mikhail Pozdnyakov 2013-05-06 09:11:20 PDT
Created attachment 200705 [details]
WIP 2
Comment 8 Build Bot 2013-05-06 09:51:28 PDT
Comment on attachment 200705 [details]
WIP 2

Attachment 200705 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/377201
Comment 9 Mikhail Pozdnyakov 2013-05-06 09:55:30 PDT
Created attachment 200714 [details]
WIP 3
Comment 10 Mikhail Pozdnyakov 2013-05-06 11:18:17 PDT
Created attachment 200724 [details]
patch
Comment 11 WebKit Commit Bot 2013-05-07 00:22:55 PDT
Comment on attachment 200724 [details]
patch

Clearing flags on attachment: 200724

Committed r149665: <http://trac.webkit.org/changeset/149665>
Comment 12 WebKit Commit Bot 2013-05-07 00:22:58 PDT
All reviewed patches have been landed.  Closing bug.
Comment 13 Darin Adler 2013-05-26 18:10:55 PDT
*** Bug 72477 has been marked as a duplicate of this bug. ***