Bug 115228

Summary: Add support for Web IDL partial interfaces to the bindings generator
Product: WebKit Reporter: Chris Dumez <cdumez>
Component: Tools / TestsAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, commit-queue, haraken, laszlo.gombos, rniwa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
URL: http://dev.w3.org/2006/webapi/WebIDL/#dfn-partial-interface
Attachments:
Description Flags
Patch none

Description Chris Dumez 2013-04-25 23:31:21 PDT
WebKit currently uses a WebKit-specific [Supplemental] extended attribute. Partial interfaces in standard Web IDL would allow us to do the same thing:
http://dev.w3.org/2006/webapi/WebIDL/#dfn-partial-interface
Comment 1 Chris Dumez 2013-04-25 23:55:21 PDT
Created attachment 199788 [details]
Patch
Comment 2 Kentaro Hara 2013-04-26 00:00:24 PDT
Comment on attachment 199788 [details]
Patch

Looks great!
Comment 3 WebKit Commit Bot 2013-04-26 00:28:16 PDT
Comment on attachment 199788 [details]
Patch

Clearing flags on attachment: 199788

Committed r149170: <http://trac.webkit.org/changeset/149170>
Comment 4 WebKit Commit Bot 2013-04-26 00:28:18 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Chris Dumez 2013-04-30 01:02:55 PDT
*** Bug 115399 has been marked as a duplicate of this bug. ***