Bug 114874

Summary: Refactor transform code in StyleResolver
Product: WebKit Reporter: Dirk Schulze <krit>
Component: CSSAssignee: Dirk Schulze <krit>
Status: RESOLVED FIXED    
Severity: Normal CC: allan.jensen, commit-queue, esprehn+autocc, gyuyoung.kim, macpherson, menard, rakuco
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Dirk Schulze 2013-04-19 07:09:52 PDT
Refactor transform code in StyleResolver. It should be in it's own file.
Comment 1 Dirk Schulze 2013-04-19 07:15:36 PDT
Created attachment 198853 [details]
Patch
Comment 2 WebKit Commit Bot 2013-04-19 07:18:46 PDT
Attachment 198853 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/WebCore/ChangeLog', u'Source/WebCore/GNUmakefile.list.am', u'Source/WebCore/Target.pri', u'Source/WebCore/WebCore.vcproj/WebCore.vcproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj.filters', u'Source/WebCore/WebCore.xcodeproj/project.pbxproj', u'Source/WebCore/css/StyleResolver.cpp', u'Source/WebCore/css/StyleResolver.h', u'Source/WebCore/css/TransformFunctions.cpp', u'Source/WebCore/css/TransformFunctions.h', u'Source/WebCore/css/WebKitCSSMatrix.cpp']" exit_code: 1
Source/WebCore/css/TransformFunctions.cpp:285:  When wrapping a line, only indent 4 spaces.  [whitespace/indent] [3]
Source/WebCore/css/TransformFunctions.cpp:296:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/css/TransformFunctions.cpp:297:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 3 in 12 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2013-04-19 08:17:20 PDT
Comment on attachment 198853 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=198853&action=review

r=me

> Source/WebCore/css/TransformFunctions.h:41
> +bool transformsForValue(const RenderStyle*, const RenderStyle* rootStyle, CSSValue*, TransformOperations&);

Can we make the CSSValue* argument const here?
Comment 4 Dirk Schulze 2013-04-19 08:30:51 PDT
(In reply to comment #3)
> (From update of attachment 198853 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=198853&action=review
> 
> r=me
> 
> > Source/WebCore/css/TransformFunctions.h:41
> > +bool transformsForValue(const RenderStyle*, const RenderStyle* rootStyle, CSSValue*, TransformOperations&);
> 
> Can we make the CSSValue* argument const here?

I tried to, that is why I pinged you about the CSSValueListIterator. It will be possible soon.
Comment 5 WebKit Commit Bot 2013-04-19 10:16:27 PDT
Comment on attachment 198853 [details]
Patch

Clearing flags on attachment: 198853

Committed r148753: <http://trac.webkit.org/changeset/148753>
Comment 6 WebKit Commit Bot 2013-04-19 10:16:30 PDT
All reviewed patches have been landed.  Closing bug.