Bug 113524

Summary: [Chromium] Don't create SolidColorLayer for full transparent background
Product: WebKit Reporter: Xianzhu Wang <wangxianzhu>
Component: Layout and RenderingAssignee: Xianzhu Wang <wangxianzhu>
Status: RESOLVED FIXED    
Severity: Normal CC: cc-bugs, enne, jamesr, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Xianzhu Wang 2013-03-28 11:55:36 PDT
http://trac.webkit.org/changeset/146826 which enabled solidColorLayer on Chromium breaks Chromium-Android.
I'd like to disable it temporarily until we support it for impl-side-painting.
Comment 1 James Robinson 2013-03-28 12:16:01 PDT
It's supported today, isn't it?
Comment 2 James Robinson 2013-03-28 12:23:30 PDT
http://trac.webkit.org/export/147140/trunk/LayoutTests/compositing/geometry/fixed-in-composited.html triggers the solid color layer path and works fine with impl-side painting on my linux box.
Comment 3 Xianzhu Wang 2013-03-28 14:50:54 PDT
The scrolling problem on Android is caused by a full-transparent SolidColorLayer over a scrollable layer.
Comment 4 James Robinson 2013-03-28 14:57:10 PDT
Ah, I see - is the fully transparent layer eating input events or something like that?  If something's fully transparent then we definitely shouldn't make any layer at all.
Comment 5 Xianzhu Wang 2013-03-28 14:59:44 PDT
(In reply to comment #4)
> Ah, I see - is the fully transparent layer eating input events or something like that?

Yes. The compositor selects the transparent solid color layer instead of the scrollable layer under it as the potentially scrolling layer.
Comment 6 Xianzhu Wang 2013-03-28 15:29:18 PDT
Created attachment 195658 [details]
Patch
Comment 7 James Robinson 2013-03-28 15:37:11 PDT
Comment on attachment 195658 [details]
Patch

Nice.
Comment 8 WebKit Review Bot 2013-03-28 16:06:59 PDT
Comment on attachment 195658 [details]
Patch

Clearing flags on attachment: 195658

Committed r147178: <http://trac.webkit.org/changeset/147178>
Comment 9 WebKit Review Bot 2013-03-28 16:07:03 PDT
All reviewed patches have been landed.  Closing bug.