Bug 113236

Summary: JSObject::enterDictionaryIndexingMode doesn't have a case for ALL_BLANK_INDEXING_TYPES
Product: WebKit Reporter: Mark Hahnenberg <mhahnenberg>
Component: JavaScriptCoreAssignee: Mark Hahnenberg <mhahnenberg>
Status: RESOLVED FIXED    
Severity: Normal CC: erights, fpizlo, ggaren, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Mark Hahnenberg 2013-03-25 12:57:47 PDT
It needs one, or else we can cause crashes because we won't actually create the ArrayStorage.
Comment 1 Mark Hahnenberg 2013-03-25 13:09:58 PDT
<rdar://problem/13489189>
Comment 2 Mark Hahnenberg 2013-03-25 13:32:34 PDT
Created attachment 194914 [details]
Patch
Comment 3 Geoffrey Garen 2013-03-25 15:47:10 PDT
Comment on attachment 194914 [details]
Patch

r=me
Comment 4 WebKit Review Bot 2013-03-25 17:17:15 PDT
Comment on attachment 194914 [details]
Patch

Clearing flags on attachment: 194914

Committed r146829: <http://trac.webkit.org/changeset/146829>
Comment 5 WebKit Review Bot 2013-03-25 17:17:18 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Alexey Proskuryakov 2021-05-07 13:04:54 PDT
*** Bug 112954 has been marked as a duplicate of this bug. ***