Bug 111585

Summary: [CSS Regions] The presence of a flow-from declaration in a CSS rule using :hover effectively disables the rule
Product: WebKit Reporter: Mihai Balan <mibalan>
Component: CSSAssignee: Radu Stavila <stavila>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, stavila, WebkitBugTracker
Priority: P2 Keywords: AdobeTracked
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 7555    
Bug Blocks: 57312, 117259, 117261    
Attachments:
Description Flags
HTML file highlighting the problem
none
Patch none

Description Mihai Balan 2013-03-06 08:36:43 PST
If a CSS rule that uses the :hover pseudo-class tries to change the value of the flow-from property, that rule seems to be effectively ignored. Removing the flow-from declaration from the rule lets all other property changes to apply.

In the attached test-case, try moving the mouse over the green square.

EXPECTED: the green square should turn red (border color changes) and the black square should turn green (content is not flowed anymore and background color - green - is revealed)

ACTUAL: nothing happens

If the -webkit-flow-from: none; declaration is dropped from the #region:hover rule, the green square will turn red (border color changes).
Comment 1 Mihai Balan 2013-03-06 08:37:19 PST
Created attachment 191758 [details]
HTML file highlighting the problem
Comment 2 Mihai Balan 2013-03-06 08:39:17 PST
However, the rule is not actually disabled, since forcing the :hover state on the region (via the Web Inspector for instance), produces the expected results.
Comment 3 Radu Stavila 2013-05-28 05:12:14 PDT
This is not a bug that affects just regions. Basically, changing any style in the :hover class that requires the element to be detached and reattached (such as changing it's display property) causes the :hover class to be ignored.
Comment 4 Radu Stavila 2013-05-30 08:49:28 PDT
Linked issue: https://bugs.webkit.org/show_bug.cgi?id=7555
Comment 5 Radu Stavila 2013-06-07 01:49:12 PDT
Created attachment 204014 [details]
Patch

The actual problem was fixed by https://bugs.webkit.org/show_bug.cgi?id=7555

This patch only adds tests for this particular problem (changing flow-from and flow-into inside :hover).
Comment 6 Mihai Maerean 2013-06-07 02:49:33 PDT
Comment on attachment 204014 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=204014&action=review

> LayoutTests/fast/regions/hover-single-flow-from-none.html:47
> +			testRunner.notifyDone();

is this really needed? If you remove the calls to waitUntilDone and notifyDone, will the test still work?

> LayoutTests/fast/regions/hover-single-flow-from-other.html:54
> +			testRunner.notifyDone();

the previous comment applies to this test too.
Comment 7 WebKit Commit Bot 2013-06-07 03:07:16 PDT
Comment on attachment 204014 [details]
Patch

Clearing flags on attachment: 204014

Committed r151311: <http://trac.webkit.org/changeset/151311>
Comment 8 WebKit Commit Bot 2013-06-07 03:07:18 PDT
All reviewed patches have been landed.  Closing bug.