Bug 11147

Summary: Safari freezes at symantec.com
Product: WebKit Reporter: Henk <henk.kampman@secondmove.com>
Component: Page LoadingAssignee: Brent Fulgham <bfulgham@webkit.org>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: alexis@webkit.org, alice.liu@apple.com, ap@webkit.org, bfulgham@webkit.org, commit-queue@webkit.org, esprehn+autocc@chromium.org, glenn@skynav.com, gyuyoung.kim@webkit.org, macpherson@chromium.org, mitz@webkit.org, troyb@omnigroup.com
Priority: P2 Keywords: InRadar, ReviewedForRadar
Version: 419.x   
Hardware: Macintosh   
OS: Mac OS X 10.4   
URL: http://www.symantec.com/
Attachments:
Description Flags
Reduction of script execution order issue
none
Not the patch for THIS bug. Ignore none

Description From 2006-10-04 01:58:14 PST
Goto: http://www.symantec.com/
Click on "products"

At this point Safari freezes (uses almost 100% cpu time).

It's fully reproducable on the two machines (PowerMacG5 DP 2.0Ghz, Intel iMac both running 10.4.8) I tried.
------- Comment #1 From 2006-10-04 02:08:46 PST -------
Also reproducable with the latest nightly (r16763)
------- Comment #2 From 2006-10-04 05:21:45 PST -------
http://www.symantec.com/script/20061003b/OmniScript_init.js:

while( !( CheckVar( "window.OmniArray" ) ) ){}

Sure enough, this freezes WebKit. Sounds highly related to bug 7722.
------- Comment #3 From 2006-10-04 06:07:36 PST -------
Created an attachment (id=10890) [details]
Reduction of script execution order issue

(In reply to comment #2)

> Sure enough, this freezes WebKit. Sounds highly related to bug 7722.

Indeed. In this reduction, the first time you open order.html, the execution order is 12. If you then open order.html in a new window, the order changes to 21. If you reload, it's 12 again.
------- Comment #4 From 2006-10-04 06:08:54 PST -------
Changing to P2 since this isn't a regression and TOT has the hooks for terminating runaway scripts, so this isn't a freeze either.
------- Comment #5 From 2006-10-04 09:36:27 PST -------
I suspect that Apple might want to fix this sooner than TOT ships... Adding HitListCandidate and NeedsRadar keywords, CC'ing Alice to prioritize this issue.
------- Comment #6 From 2006-11-08 16:01:44 PST -------
radar 4765923
------- Comment #7 From 2014-04-03 15:35:39 PST -------
Created an attachment (id=228549) [details]
Patch
------- Comment #8 From 2014-04-03 15:37:20 PST -------
Uploaded a patch to this bug by accident. Nothing to see here.
------- Comment #9 From 2014-04-04 11:22:15 PST -------
The site works for me now.