Bug 110844

Summary: REGRESSION (r143931): set-cookie-on-redirect.html breaks subsequent tests
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Tools / TestsAssignee: Sergio Villar Senin <svillar>
Status: RESOLVED FIXED    
Severity: Normal CC: beidson, cgarcia, dino, mrobinson, roger_fong, svillar, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Alexey Proskuryakov 2013-02-25 21:34:28 PST
This test doesn't clean up cookies, so they show up in subsequent tests, and in particular break third-party-cookie-relaxing.html, because it depends on whether there are already cookies set for the particular first party.

Bots hide this misbehavior, because they re-run failing tests, this time without set-cookie-on-redirect.html.

Sergio, can you please look into this? I think that the patch will need to be rolled out if this cannot be fixed soon.
Comment 1 Sergio Villar Senin 2013-02-26 00:39:17 PST
(In reply to comment #0)
> This test doesn't clean up cookies, so they show up in subsequent tests, and in particular break third-party-cookie-relaxing.html, because it depends on whether there are already cookies set for the particular first party.
> 
> Bots hide this misbehavior, because they re-run failing tests, this time without set-cookie-on-redirect.html.
> 
> Sergio, can you please look into this? I think that the patch will need to be rolled out if this cannot be fixed soon.

Sure.

It's true that the test I added does not clean up cookies, but in any case, shouldn't third-party-cookie-relaxing.html call clearAllCookies() at the beginning as the other tests do?
Comment 2 Alexey Proskuryakov 2013-02-26 00:48:33 PST
Possibly. Cookie testing machinery is extremely fragile, and I'm not sure if that would help.
Comment 3 Sergio Villar Senin 2013-02-26 01:28:37 PST
Created attachment 190237 [details]
Patch
Comment 4 WebKit Review Bot 2013-02-26 05:39:20 PST
Comment on attachment 190237 [details]
Patch

Clearing flags on attachment: 190237

Committed r144045: <http://trac.webkit.org/changeset/144045>
Comment 5 WebKit Review Bot 2013-02-26 05:39:23 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Alexey Proskuryakov 2013-02-26 10:13:01 PST
Confirmed that the patch helped on Mac. Thank you!
Comment 7 Dean Jackson 2013-03-06 17:14:00 PST
More reports in https://bugs.webkit.org/show_bug.cgi?id=111650