Bug 110208

Summary: Allow to retrieve the request data from abstract TextCheckingRequest to be accessible for WK2
Product: WebKit Reporter: Grzegorz Czajkowski <g.czajkowski>
Component: HTML EditingAssignee: Grzegorz Czajkowski <g.czajkowski>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, buildbot, enrica, mifenton, morrita, rniwa, rwlbuis, tonikitoo, webkit.review.bot, yong.li.webkit
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 109577    
Attachments:
Description Flags
proposed patch
none
TextCheckingRequestData as a member of TextCheckingRequest
buildbot: commit-queue-
hopefully fixes Mac build
morrita: review+
apply Morrita's suggestions none

Grzegorz Czajkowski
Reported 2013-02-19 04:19:51 PST
The WebCore changes are required to implement asynchronous spell checking in WK2. The idea of asynchronous spell checking in WK1 is to pass the pointer to the abstract object to the client who is able to verify the given text and notify the WebCore about results. WK2 will extract the request data from TextCheckingRequest and pass it (with additional information) to the UIProcess.
Attachments
proposed patch (4.43 KB, patch)
2013-02-19 04:29 PST, Grzegorz Czajkowski
no flags
TextCheckingRequestData as a member of TextCheckingRequest (14.54 KB, patch)
2013-02-20 03:48 PST, Grzegorz Czajkowski
buildbot: commit-queue-
hopefully fixes Mac build (15.10 KB, patch)
2013-02-20 05:54 PST, Grzegorz Czajkowski
morrita: review+
apply Morrita's suggestions (15.96 KB, patch)
2013-02-21 02:40 PST, Grzegorz Czajkowski
no flags
Grzegorz Czajkowski
Comment 1 2013-02-19 04:29:38 PST
Created attachment 189054 [details] proposed patch
Hajime Morrita
Comment 2 2013-02-19 19:16:30 PST
Comment on attachment 189054 [details] proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=189054&action=review > Source/WebCore/platform/text/TextChecking.h:119 > +class TextCheckingRequest : public RefCounted<TextCheckingRequest>, public TextCheckingRequestData { Using inheritance here should be avoidable if possible. Why not just turns it a member? This looks a typical composition over inheritance situation.
Hajime Morrita
Comment 3 2013-02-19 19:34:11 PST
(In reply to comment #2) > Using inheritance here should be avoidable if possible. Why not just turns it a member? s/avoidable/avoided/
Grzegorz Czajkowski
Comment 4 2013-02-20 03:48:37 PST
Created attachment 189279 [details] TextCheckingRequestData as a member of TextCheckingRequest
Build Bot
Comment 5 2013-02-20 04:23:33 PST
Comment on attachment 189279 [details] TextCheckingRequestData as a member of TextCheckingRequest Attachment 189279 [details] did not pass mac-wk2-ews (mac-wk2): Output: http://queues.webkit.org/results/16655269
Grzegorz Czajkowski
Comment 6 2013-02-20 05:54:20 PST
Created attachment 189298 [details] hopefully fixes Mac build
Hajime Morrita
Comment 7 2013-02-21 00:05:13 PST
Comment on attachment 189298 [details] hopefully fixes Mac build View in context: https://bugs.webkit.org/attachment.cgi?id=189298&action=review Looks good overall. Could you polish a bit more? > Source/WebCore/platform/text/TextChecking.h:91 > +const int unrequestedSequence = -1; Could you move this into some classes or change the name a bit more verbose? The name is too ambiguous to be WebCore global. > Source/WebCore/platform/text/TextChecking.h:130 > + const TextCheckingRequestData& data() const { return m_requestData; } Looks like we no longer need to have m_requestData in this class. It can be pushed down to SpellCheckRequest then data() can be pure virtual.
Grzegorz Czajkowski
Comment 8 2013-02-21 02:40:45 PST
Created attachment 189488 [details] apply Morrita's suggestions
Grzegorz Czajkowski
Comment 9 2013-02-21 02:45:36 PST
(In reply to comment #7) > (From update of attachment 189298 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=189298&action=review > > Looks good overall. Could you polish a bit more? > > > Source/WebCore/platform/text/TextChecking.h:91 > > +const int unrequestedSequence = -1;> > Could you move this into some classes or change the name a bit more verbose? > The name is too ambiguous to be WebCore global. Sure, changed to 'unrequestedTextCheckingSequence'. > > > Source/WebCore/platform/text/TextChecking.h:130 > > + const TextCheckingRequestData& data() const { return m_requestData; } > > Looks like we no longer need to have m_requestData in this class. It can be pushed down to SpellCheckRequest then data() can be pure virtual. Definitely, done. Thanks for great review. Is it ok for you now?
Hajime Morrita
Comment 10 2013-02-21 21:42:33 PST
Comment on attachment 189488 [details] apply Morrita's suggestions thanks for the update!
WebKit Review Bot
Comment 11 2013-02-21 22:03:45 PST
Comment on attachment 189488 [details] apply Morrita's suggestions Clearing flags on attachment: 189488 Committed r143688: <http://trac.webkit.org/changeset/143688>
WebKit Review Bot
Comment 12 2013-02-21 22:03:51 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.