Bug 109780

Summary: [Regression] After r142831 collection-null-like-arguments.html layout test failing
Product: WebKit Reporter: Vineet Chaudhary (vineetc) <code.vineet>
Component: New BugsAssignee: Vineet Chaudhary (vineetc) <code.vineet>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, haraken, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch none

Description Vineet Chaudhary (vineetc) 2013-02-13 19:37:28 PST
After r142831:
LayoutTests/fast/dom/collection-null-like-arguments.html is failing for JSC bindings.
Comment 1 Vineet Chaudhary (vineetc) 2013-02-13 19:52:13 PST
Created attachment 188251 [details]
patch

As per specification only for namedItem() it should return null if collection is empty.
@r142831 caused regression because it was returning null from getNamedItems() directly.
Comment 2 Kentaro Hara 2013-02-13 19:54:10 PST
Comment on attachment 188251 [details]
patch

Looks reasonable. Thanks for the quick fix.
Comment 3 WebKit Review Bot 2013-02-13 20:19:20 PST
Comment on attachment 188251 [details]
patch

Clearing flags on attachment: 188251

Committed r142846: <http://trac.webkit.org/changeset/142846>
Comment 4 WebKit Review Bot 2013-02-13 20:19:23 PST
All reviewed patches have been landed.  Closing bug.