Bug 109348

Summary: ScrollingTree node maps keep getting larger
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: Layout and RenderingAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, andersca, bdakin, jamesr, sam, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch sam: review+

Description Simon Fraser (smfr) 2013-02-08 22:12:46 PST
Both the ScrollingCoordinator's m_stateNodeMap and ScrollingTree's m_nodeMap get larger and larger as you navigate between pages.
Comment 1 Simon Fraser (smfr) 2013-02-09 13:01:22 PST
Created attachment 187441 [details]
Patch
Comment 2 Simon Fraser (smfr) 2013-02-09 13:02:04 PST
This patch depends on the patch in bug 109361, so will probably fail EWS.
Comment 3 Simon Fraser (smfr) 2013-02-09 13:03:28 PST
The changelog should say that this isn't testable, because we only dump the state node tree (which is OK), not the hash map. The scrolling node tree does accumulate extra children, but we don't dump that.
Comment 4 Simon Fraser (smfr) 2013-02-11 13:30:16 PST
http://trac.webkit.org/changeset/142505
Comment 5 Simon Fraser (smfr) 2013-02-11 13:30:52 PST
*** Bug 108732 has been marked as a duplicate of this bug. ***