Bug 108682

Summary: [GStreamer] media/video-controls-fullscreen-volume.html crashes
Product: WebKit Reporter: Philippe Normand <pnormand>
Component: PlatformAssignee: Ms2ger (he/him; ⌚ UTC+1/+2) <Ms2ger>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric.carlson, feature-media-reviews, gns, menard, mrobinson, Ms2ger, pnormand, webkit-bug-importer, webkit.review.bot, zan
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Philippe Normand 2013-02-01 13:21:58 PST
#0  0x00002ac0201b50b4 in WebCore::FullscreenVideoControllerGtk::muteChanged (this=<error reading variable: Cannot access memory at address 0x7fffceffffe8>, this@entry=<error reading variable: Cannot access memory at address 0x7fffcf000008>) at ../../Source/WebCore/platform/graphics/gtk/FullscreenVideoControllerGtk.cpp:343
343	    gtk_scale_button_set_value(GTK_SCALE_BUTTON(m_volumeButton), m_player->muted() ? 0 : m_player->volume());

Maybe a signal handler is not disconnected correctly.
Comment 1 Philippe Normand 2013-02-01 13:22:44 PST
Also crashing but no crash log:

media/video-controls-visible-exiting-fullscreen.html
media/video-src.html
Comment 2 Philippe Normand 2013-02-01 13:28:03 PST
Flagged in r141636
Comment 3 Philippe Normand 2013-02-10 05:37:31 PST
Created attachment 187478 [details]
Patch
Comment 4 Philippe Normand 2013-02-10 09:31:32 PST
Committed r142406: <http://trac.webkit.org/changeset/142406>
Comment 5 Philippe Normand 2013-02-11 00:34:47 PST
The issue is still happening on the Debug bot. Going to flag tests and upload a new patch. I don't think the current one needs to be rolled out.
Comment 6 Philippe Normand 2014-03-04 23:59:29 PST
Native fullscreen video display support was removed. Closing.
Comment 7 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-18 08:50:35 PDT
Reopening to attach new patch.
Comment 8 Ms2ger (he/him; ⌚ UTC+1/+2) 2017-08-18 08:50:37 PDT
Created attachment 318500 [details]
Patch
Comment 9 WebKit Commit Bot 2017-08-21 01:28:52 PDT
Comment on attachment 318500 [details]
Patch

Clearing flags on attachment: 318500

Committed r220961: <http://trac.webkit.org/changeset/220961>
Comment 10 WebKit Commit Bot 2017-08-21 01:28:54 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 Radar WebKit Bug Importer 2017-08-21 01:29:34 PDT
<rdar://problem/33988256>