Bug 108455

Summary: Implement WheelEvent::deltaMode
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, ojan.autocc, sam, webkit.review.bot
Priority: P2 Keywords: WebExposed
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch abarth: review+

Kentaro Hara
Reported 2013-01-31 04:00:39 PST
Per the spec, WheelEvent::deltaMode should return DOM_DELTA_PIXEL or DOM_DELTA_LINE or DOM_DELTA_PAGE. Spec: http://www.w3.org/TR/DOM-Level-3-Events/#events-wheelevents https://dvcs.w3.org/hg/d4e/raw-file/tip/source_respec.htm#constructor-wheelevent
Attachments
Patch (38.27 KB, patch)
2013-01-31 04:08 PST, Kentaro Hara
no flags
Patch (38.49 KB, patch)
2013-01-31 16:44 PST, Kentaro Hara
abarth: review+
Kentaro Hara
Comment 1 2013-01-31 04:08:03 PST
WebKit Review Bot
Comment 2 2013-01-31 04:10:11 PST
Attachment 185740 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast/events/constructors/wheel-event-constructor-expected.txt', u'LayoutTests/fast/events/constructors/wheel-event-constructor.html', u'Source/WebCore/ChangeLog', u'Source/WebCore/dom/WheelEvent.cpp', u'Source/WebCore/dom/WheelEvent.h', u'Source/WebCore/dom/WheelEvent.idl', u'Source/WebCore/page/EventHandler.cpp', u'Source/WebKit/chromium/ChangeLog', u'Source/WebKit/chromium/src/WebInputEventConversion.cpp']" exit_code: 1 Source/WebCore/dom/WheelEvent.h:46: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Source/WebCore/dom/WheelEvent.h:47: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Source/WebCore/dom/WheelEvent.h:48: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Total errors found: 3 in 10 files If any of these errors are false positives, please file a bug against check-webkit-style.
Kentaro Hara
Comment 3 2013-01-31 04:13:55 PST
Comment on attachment 185740 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=185740&action=review >> Source/WebCore/dom/WheelEvent.h:46 >> + DOM_DELTA_PIXEL = 0, > > enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] This is OK. We conventionally use the same constant name as the Web IDL spec.
Adam Barth
Comment 4 2013-01-31 10:33:41 PST
Comment on attachment 185740 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=185740&action=review > Source/WebCore/dom/WheelEvent.idl:28 > + const unsigned long DOM_DELTA_PIXEL = 0x00; > + const unsigned long DOM_DELTA_LINE = 0x01; > + const unsigned long DOM_DELTA_PAGE = 0x02; > + Are these constants on the WheelEvent constructor or on the instances? > Source/WebCore/page/EventHandler.cpp:256 > switch (deltaMode) { Should we add a default case to this switch now that the type of deltaMode is unsigned rather than WheelEvent::DeltaMode ?
Adam Barth
Comment 5 2013-01-31 10:36:09 PST
The spec says: ---8<--- Initializes the deltaMode attribute on the WheelEvent object to the enumerated values 0, 1, or 2, which represent the amount of pixels scrolled (DOM_DELTA_PIXEL), lines scrolled (DOM_DELTA_LINE), or pages scrolled (DOM_DELTA_PAGE) if the rotation of the wheel would have resulted in scrolling. --->8--- Does that mean the constructor should enforce that deltaMode is only initialized to 0, 1, or 2? If the caller supplies the value 42, what is supposed to happen?
Kentaro Hara
Comment 6 2013-01-31 16:44:02 PST
Kentaro Hara
Comment 7 2013-01-31 16:44:19 PST
(In reply to comment #4) > > Source/WebCore/dom/WheelEvent.idl:28 > > + const unsigned long DOM_DELTA_PIXEL = 0x00; > > + const unsigned long DOM_DELTA_LINE = 0x01; > > + const unsigned long DOM_DELTA_PAGE = 0x02; > > + > > Are these constants on the WheelEvent constructor or on the instances? Both. The spec requires both (http://www.w3.org/TR/WebIDL/#es-constants). The WebKit implementation is conformant with the spec. > > Source/WebCore/page/EventHandler.cpp:256 > > switch (deltaMode) { > > Should we add a default case to this switch now that the type of deltaMode is unsigned rather than WheelEvent::DeltaMode ? Done. > The spec says: > > ---8<--- > Initializes the deltaMode attribute on the WheelEvent object to the enumerated values 0, 1, or 2, which represent the amount of pixels scrolled (DOM_DELTA_PIXEL), lines scrolled (DOM_DELTA_LINE), or pages scrolled (DOM_DELTA_PAGE) if the rotation of the wheel would have resulted in scrolling. > --->8--- > > Does that mean the constructor should enforce that deltaMode is only initialized to 0, 1, or 2? If the caller supplies the value 42, what is supposed to happen? Good point. As far as I read the spec, I couldn't find any explicit description about that. Given that the type of deltaMode is unsigned, I think the behavior should follow the spec of normal unsigned attributes. If so, assigning 42 will result in 42. (c.f. If deltaMode is speced as enum, invalid value assignment will be simply ignored. http://www.w3.org/TR/WebIDL/#idl-enums)
WebKit Review Bot
Comment 8 2013-01-31 16:47:52 PST
Attachment 185895 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast/events/constructors/wheel-event-constructor-expected.txt', u'LayoutTests/fast/events/constructors/wheel-event-constructor.html', u'Source/WebCore/ChangeLog', u'Source/WebCore/dom/WheelEvent.cpp', u'Source/WebCore/dom/WheelEvent.h', u'Source/WebCore/dom/WheelEvent.idl', u'Source/WebCore/page/EventHandler.cpp', u'Source/WebKit/chromium/ChangeLog', u'Source/WebKit/chromium/src/WebInputEventConversion.cpp']" exit_code: 1 Source/WebCore/dom/WheelEvent.h:46: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Source/WebCore/dom/WheelEvent.h:47: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Source/WebCore/dom/WheelEvent.h:48: enum members should use InterCaps with an initial capital letter. [readability/enum_casing] [4] Total errors found: 3 in 10 files If any of these errors are false positives, please file a bug against check-webkit-style.
Adam Barth
Comment 9 2013-02-01 00:21:50 PST
Comment on attachment 185895 [details] Patch Ok. Would you be willing to double-check with the working group about the out-of-bounds case?
Kentaro Hara
Comment 10 2013-02-01 00:34:41 PST
(In reply to comment #9) > (From update of attachment 185895 [details]) > Ok. Would you be willing to double-check with the working group about the out-of-bounds case? Sure. Will do before landing.
Kentaro Hara
Comment 11 2013-02-04 15:50:39 PST
(In reply to comment #10) > (In reply to comment #9) > > (From update of attachment 185895 [details] [details]) > > Ok. Would you be willing to double-check with the working group about the out-of-bounds case? > > Sure. Will do before landing. I discussed with spec authors. In conclusion, we can set out-of-bound values: https://www.w3.org/Bugs/Public/show_bug.cgi?id=14053#c6 Will land the patch soon.
Kentaro Hara
Comment 12 2013-02-04 15:56:51 PST
Note You need to log in before you can comment on or make changes to this bug.