Bug 108421

Summary: REGRESSION(r141358): breaks android builder (Requested by morrita on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED FIXED    
Severity: Normal CC: haraken, thakis
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108408    
Attachments:
Description Flags
ROLLOUT of r141358 none

Description WebKit Review Bot 2013-01-30 20:47:59 PST
http://trac.webkit.org/changeset/141358 broke the build:
breaks android builder (Requested by morrita on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2013-01-30 20:48:27 PST
Created attachment 185669 [details]
ROLLOUT of r141358

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Nico Weber 2013-01-30 20:57:16 PST
Partial build output:

FAILED: if [ ! -e lib/libDumpRenderTree.so -o ! -e lib/libDumpRenderTree.so.TOC ]; then flock linker.lock /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/arm-linux-androideabi-g++ -shared -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -fPIC -fuse-ld=gold -nostdlib -Wl,--no-undefined --sysroot=/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm -Wl,--icf=safe -L/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//sources/cxx-stl/stlport/libs/armeabi-v7a -L/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a -Wl,-shared,-Bsymbolic /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm/usr/lib/crtbegin_so.o -Wl,-O1 -Wl,--as-needed -Wl,--gc-sections -o lib/libDumpRenderTree.so -Wl,-soname=libDumpRenderTree.so -Wl,--whole-archive obj/Tools/DumpRenderTree/DumpRenderTree.DumpRenderTreeCommon.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DRTDevToolsAgent.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DRTDevToolsClient.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DumpRenderTree.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockConstraints.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebKitPlatformSupport.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebMediaStreamCenter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebPrerenderingSupport.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebRTCPeerConnectionHandler.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebRTCDataChannelHandler.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebSpeechInputController.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebSpeechRecognizer.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.NotificationPresenter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.Task.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestEventPrinter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestNavigationController.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShell.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellAndroid.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellPosix.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellStub.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebUserMediaClientMock.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebViewHost.o libgmock.a libwebp_enc.a libplayer_android.a libtess.a libwebcore_test_support.a libgles2_cmd_helper.a libwebcore_svg.a libwebkit_compositor_bindings.a libsymbolize.a libppapi_shared.a libv8-i18n.a libmedia.a libwebkit_media.a libgtest.a libwebkit_storage.a libcc.a libsdch.a libwebp_dsp.a libwebcore_rendering.a libtranslator_glsl.a libwebkit_gpu.a libtranslator_common.a libopus.a libwebcore_platform_geometry.a libhyphen.a libnative_theme.a libwebkit.a libbase.a libcommand_buffer_service.a libgles2_c_lib.a libwtf.a libcommand_buffer_client.a libsql.a liballocator_extension_thunks.a libwebcore_html.a libglue.a libui.a libsqlite3.a libwebkit_support_gfx.a libicudata.a libiccjpeg.a libgles2_implementation.a libsurface.a libwebkit_test_support.a libv8_nosnapshot.a libevent.a libTestRunner.a libuser_agent.a libwebcore_platform.a libwebcore_remaining.a libwebkit_support_common.a libwebcore_arm_neon.a libcommand_buffer_common.a libwebp_utils.a libwebcore_dom.a libgoogleurl.a libxslt.a libots.a libchrome_zlib.a libbase_static.a libwebkit_base.a libmodp_b64.a libwebcore_bindings.a libjpeg_turbo.a libcrcrypto.a libxml2.a libshared_memory_support.a libexpat.a libpreprocessor.a libwebkit_wtf_support.a libyuv_convert.a libyarr.a libdynamic_annotations.a libskia.a libgl_wrapper.a libwebkit_platform.a libqcms.a libwebp_dsp_neon.a libtest_support_base.a libwebp_dec.a libnet.a libopenssl.a libleveldatabase.a libyuv_convert_simd_c.a libcityhash.a libwebkit_support.a libbase_i18n.a libashmem.a libprinting.a libicui18n.a libwebkit_compositor_support.a libv8_base.a libicuuc.a libft2.a libharfbuzz-ng.a libpng.a libnative_test_native_code.a libcpu_features.a libskia_opts.a libgles2_utils.a  -Wl,--no-whole-archive -llog -ljnigraphics -lOpenSLES -lstlport_static /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/libgcc.a -lc -ldl -lstdc++ -lm /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm/usr/lib/crtend_so.o && { readelf -d lib/libDumpRenderTree.so | grep SONAME ; nm -gD -f p lib/libDumpRenderTree.so | cut -f1-2 -d' '; } > lib/libDumpRenderTree.so.TOC; else flock linker.lock /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/arm-linux-androideabi-g++ -shared -Wl,-z,now -Wl,-z,relro -Wl,-z,noexecstack -fPIC -fuse-ld=gold -nostdlib -Wl,--no-undefined --sysroot=/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm -Wl,--icf=safe -L/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//sources/cxx-stl/stlport/libs/armeabi-v7a -L/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a -Wl,-shared,-Bsymbolic /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm/usr/lib/crtbegin_so.o -Wl,-O1 -Wl,--as-needed -Wl,--gc-sections -o lib/libDumpRenderTree.so -Wl,-soname=libDumpRenderTree.so -Wl,--whole-archive obj/Tools/DumpRenderTree/DumpRenderTree.DumpRenderTreeCommon.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DRTDevToolsAgent.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DRTDevToolsClient.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.DumpRenderTree.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockConstraints.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebKitPlatformSupport.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebMediaStreamCenter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebPrerenderingSupport.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebRTCPeerConnectionHandler.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebRTCDataChannelHandler.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebSpeechInputController.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.MockWebSpeechRecognizer.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.NotificationPresenter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.Task.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestEventPrinter.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestNavigationController.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShell.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellAndroid.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellPosix.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.TestShellStub.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebUserMediaClientMock.o obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebViewHost.o libgmock.a libwebp_enc.a libplayer_android.a libtess.a libwebcore_test_support.a libgles2_cmd_helper.a libwebcore_svg.a libwebkit_compositor_bindings.a libsymbolize.a libppapi_shared.a libv8-i18n.a libmedia.a libwebkit_media.a libgtest.a libwebkit_storage.a libcc.a libsdch.a libwebp_dsp.a libwebcore_rendering.a libtranslator_glsl.a libwebkit_gpu.a libtranslator_common.a libopus.a libwebcore_platform_geometry.a libhyphen.a libnative_theme.a libwebkit.a libbase.a libcommand_buffer_service.a libgles2_c_lib.a libwtf.a libcommand_buffer_client.a libsql.a liballocator_extension_thunks.a libwebcore_html.a libglue.a libui.a libsqlite3.a libwebkit_support_gfx.a libicudata.a libiccjpeg.a libgles2_implementation.a libsurface.a libwebkit_test_support.a libv8_nosnapshot.a libevent.a libTestRunner.a libuser_agent.a libwebcore_platform.a libwebcore_remaining.a libwebkit_support_common.a libwebcore_arm_neon.a libcommand_buffer_common.a libwebp_utils.a libwebcore_dom.a libgoogleurl.a libxslt.a libots.a libchrome_zlib.a libbase_static.a libwebkit_base.a libmodp_b64.a libwebcore_bindings.a libjpeg_turbo.a libcrcrypto.a libxml2.a libshared_memory_support.a libexpat.a libpreprocessor.a libwebkit_wtf_support.a libyuv_convert.a libyarr.a libdynamic_annotations.a libskia.a libgl_wrapper.a libwebkit_platform.a libqcms.a libwebp_dsp_neon.a libtest_support_base.a libwebp_dec.a libnet.a libopenssl.a libleveldatabase.a libyuv_convert_simd_c.a libcityhash.a libwebkit_support.a libbase_i18n.a libashmem.a libprinting.a libicui18n.a libwebkit_compositor_support.a libv8_base.a libicuuc.a libft2.a libharfbuzz-ng.a libpng.a libnative_test_native_code.a libcpu_features.a libskia_opts.a libgles2_utils.a  -Wl,--no-whole-archive -llog -ljnigraphics -lOpenSLES -lstlport_static /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/libgcc.a -lc -ldl -lstdc++ -lm /mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk//platforms/android-9/arch-arm/usr/lib/crtend_so.o && { readelf -d lib/libDumpRenderTree.so | grep SONAME ; nm -gD -f p lib/libDumpRenderTree.so | cut -f1-2 -d' '; } > lib/libDumpRenderTree.so.tmp && if ! cmp -s lib/libDumpRenderTree.so.tmp lib/libDumpRenderTree.so.TOC; then mv lib/libDumpRenderTree.so.tmp lib/libDumpRenderTree.so.TOC ; fi; fi
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebViewHost.o: in function .LTHUNK60:../../Source/WebKit/chromium/public/WebIntentRequest.h:56: error: undefined reference to 'WebKit::WebIntentRequest::assign(WebKit::WebIntentRequest const&)'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebViewHost.o: in function WebViewHost::~WebViewHost():../../Source/WebKit/chromium/public/WebIntentRequest.h:52: error: undefined reference to 'WebKit::WebIntentRequest::reset()'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: obj/Tools/DumpRenderTree/chromium/DumpRenderTree.WebViewHost.o: in function WebViewHost::~WebViewHost():../../Source/WebKit/chromium/public/WebIntentRequest.h:52: error: undefined reference to 'WebKit::WebIntentRequest::reset()'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: libwebkit.a(webkit.FrameLoaderClientImpl.o): in function WebKit::FrameLoaderClientImpl::dispatchIntent(WTF::PassRefPtr<WebCore::IntentRequest>):../../Source/WebKit/chromium/src/FrameLoaderClientImpl.cpp:1663: error: undefined reference to 'WebKit::WebIntentRequest::WebIntentRequest(WTF::PassRefPtr<WebCore::IntentRequest> const&)'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: libwebkit.a(webkit.FrameLoaderClientImpl.o): in function WebKit::FrameLoaderClientImpl::dispatchIntent(WTF::PassRefPtr<WebCore::IntentRequest>):../../Source/WebKit/chromium/public/WebIntentRequest.h:52: error: undefined reference to 'WebKit::WebIntentRequest::reset()'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: libwebkit.a(webkit.WebFrameImpl.o): in function WebKit::WebFrameImpl::deliverIntent(WebKit::WebIntent const&, WebKit::WebVector<WebKit::WebMessagePortChannel*>*, WebKit::WebDeliveredIntentClient*):../../Source/WebKit/chromium/src/WebFrameImpl.cpp:2079: error: undefined reference to 'WebKit::DeliveredIntentClientImpl::DeliveredIntentClientImpl(WebKit::WebDeliveredIntentClient*)'
/mnt/data/b/WebKit-BuildSlave/chromium-linux-android/build/Source/WebKit/chromium/third_party/android_tools/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.6.x-google/../../../../arm-linux-androideabi/bin/ld.gold: libwebkit.a(webkit.WebFrameImpl.o): in function WebKit::WebFrameImpl::deliverIntent(WebKit::WebIntent const&, WebKit::WebVector<WebKit::WebMessagePortChannel*>*, WebKit::WebDeliveredIntentClient*):../../Source/WebKit/chromium/src/WebFrameImpl.cpp:2081: error: undefined reference to 'WebKit::WebIntent::data() const'
/mnt/data

Looks like ENABLE_WEB_INTENTS gets set to 1 for android but the files get excluded anyhow. I'd guess that build/common.gypi doesn't set enable_web_intents for android like it does on the other ports. I'll investigate tomorrow, thanks for rolling this out.
Comment 3 WebKit Review Bot 2013-01-30 20:59:23 PST
Comment on attachment 185669 [details]
ROLLOUT of r141358

Clearing flags on attachment: 185669

Committed r141371: <http://trac.webkit.org/changeset/141371>
Comment 4 WebKit Review Bot 2013-01-30 20:59:26 PST
All reviewed patches have been landed.  Closing bug.