Bug 107964

Summary: Remove Mac OS X Leopard (10.5) support
Product: WebKit Reporter: Laszlo Gombos <laszlo.gombos>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, benjamin, buildbot, commit-queue, darin, ddkilzer, eric, hausmann, kevino, mark, mrowe, rniwa
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
proposed changes
rniwa: review+, commit-queue: commit-queue-
fixed the build break in GraphicsContextCG none

Description Laszlo Gombos 2013-01-25 10:59:37 PST
It seems to me that no WebKit port is supporting Mac OS X Leopard (10.5) any more. If my understanding of the __MAC_OS_X_VERSION_MIN_REQUIRED and MAC_OS_X_VERSION_MAX_ALLOWED  macros are correct than
 - code guarded with (__MAC_OS_X_VERSION_MIN_REQUIRED <= 1050) or (MAC_OS_X_VERSION_MAX_ALLOWED <= 1050) is dead code and should be removed.
 - (__MAC_OS_X_VERSION_MIN_REQUIRED >= 1060) and (MAC_OS_X_VERSION_MAX_ALLOWED >= 1060) guards can be simply removed - as these guards are always true
 - (__MAC_OS_X_VERSION_MIN_REQUIRED <= 1060) or (MAC_OS_X_VERSION_MAX_ALLOWED <= 1060) should be replaced with (..== 1060) for better readability.
Comment 1 Laszlo Gombos 2013-05-10 11:39:28 PDT
Created attachment 201368 [details]
proposed changes

Most of the work has been done by Ryosuke as r147447, r147525 and r147710; this patch is just a few more thing I found.
Comment 2 WebKit Commit Bot 2013-05-10 12:07:37 PDT
Comment on attachment 201368 [details]
proposed changes

Rejecting attachment 201368 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.appspot.com', '--bot-id=webkit-cq-01', 'build', '--no-clean', '--no-update', '--build-style=release', '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Last 500 characters of output:
.dia -c /Volumes/Data/EWS/WebKit/Source/WebCore/platform/graphics/GraphicsLayer.cpp -o /Volumes/Data/EWS/WebKit/WebKitBuild/WebCore.build/Release/WebCore.build/Objects-normal/x86_64/GraphicsLayer.o


** BUILD FAILED **


The following build commands failed:
	CompileC /Volumes/Data/EWS/WebKit/WebKitBuild/WebCore.build/Release/WebCore.build/Objects-normal/x86_64/GraphicsContextCG.o platform/graphics/cg/GraphicsContextCG.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)

Full output: http://webkit-queues.appspot.com/results/406616
Comment 3 Build Bot 2013-05-10 12:21:29 PDT
Comment on attachment 201368 [details]
proposed changes

Attachment 201368 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/380509
Comment 4 Laszlo Gombos 2013-05-10 12:27:08 PDT
Created attachment 201378 [details]
fixed the build break in GraphicsContextCG

(and remove even more code)
Comment 5 Laszlo Gombos 2013-05-10 12:51:28 PDT
*** Bug 90252 has been marked as a duplicate of this bug. ***
Comment 6 Laszlo Gombos 2013-05-10 13:42:00 PDT
Comment on attachment 201378 [details]
fixed the build break in GraphicsContextCG

Ryosuke, would you mind reviewing again ? Changes since the last review are in platform/graphics/cg/GraphicsContextCG.cpp . Thanks !
Comment 7 WebKit Commit Bot 2013-05-10 18:58:33 PDT
Comment on attachment 201378 [details]
fixed the build break in GraphicsContextCG

Clearing flags on attachment: 201378

Committed r149922: <http://trac.webkit.org/changeset/149922>
Comment 8 WebKit Commit Bot 2013-05-10 18:58:36 PDT
All reviewed patches have been landed.  Closing bug.