Bug 107926

Summary: make-3.82 fails to build on ARM/Linux
Product: WebKit Reporter: Keaton Mowery <kmowery>
Component: WebKitGTKAssignee: ChangSeok Oh <changseok>
Status: RESOLVED FIXED    
Severity: Normal CC: berto, changseok, commit-queue, gns, kevin.cs.oh, mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Linux   
Attachments:
Description Flags
Patch
none
Patch none

Description Keaton Mowery 2013-01-25 00:45:16 PST
Running

$ Tools/Scripts/update-webkitgtk-libs

fails as of r140691 when compiling make-3.82 on an Debian armel install (`uname -a`: "Linux huan 3.7.4-x8 #1 SMP Tue Jan 22 19:03:12 UTC 2013 armv7l GNU/Linux")

The error:

gcc -DLOCALEDIR=\"/home/kmowery/src/webkit/WebKitBuild/Dependencies/Root/share/locale\" -DLIBDIR=\"/home/kmowery/src/webkit/WebKitBuild/Dependencies/Root/lib\" -DINCLUDEDIR=\"/home/kmowery/src/webkit/We
bKitBuild/Dependencies/Root/include\" -DHAVE_CONFIG_H -I.      -g -O2 -MT main.o -MD -MP -MF .deps/main.Tpo -c -o main.o main.c
job.c: In function ‘construct_command_argv_internal’:
job.c:2883:16: error: ‘PAGE_SIZE’ undeclared (first use in this function)
job.c:2883:16: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [job.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/main.Tpo .deps/main.Po
make[2]: Leaving directory `/home/kmowery/src/webkit/WebKitBuild/Dependencies/Source/make-3.82'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kmowery/src/webkit/WebKitBuild/Dependencies/Source/make-3.82'
make: *** [all] Error 2

This error appears to be caused by the webkit-provided patch "Tools/gtk/patches/make-3.82-arg-list-length.patch".

As a workaround, truncating this file allows make-3.82 to build properly. I'm not currently sure if WebKit GTK will build with the modified make, though.
Comment 1 Alberto Garcia 2013-09-15 05:16:25 PDT
I don't see where PAGE_SIZE is used in the make source code. Maybe it's in one of the headers included by that patch?

It might be related to this: http://bugs.debian.org/393023

Do you still have the problem?
Comment 2 ChangSeok Oh 2014-03-05 21:29:27 PST
(In reply to comment #1)
> I don't see where PAGE_SIZE is used in the make source code. Maybe it's in one of the headers included by that patch?
> 
> It might be related to this: http://bugs.debian.org/393023
> 
> Do you still have the problem?

This still happens on arm device like odroid U3.
Comment 3 ChangSeok Oh 2014-03-06 00:07:23 PST
Created attachment 225960 [details]
Patch
Comment 4 ChangSeok Oh 2014-03-06 01:48:52 PST
Created attachment 225968 [details]
Patch
Comment 5 WebKit Commit Bot 2014-03-06 06:55:29 PST
Comment on attachment 225968 [details]
Patch

Clearing flags on attachment: 225968

Committed r165189: <http://trac.webkit.org/changeset/165189>
Comment 6 WebKit Commit Bot 2014-03-06 06:55:31 PST
All reviewed patches have been landed.  Closing bug.