Bug 106777

Summary: Web Inspector: [Qt] Regression: the script option 'always enable' doesn't persist
Product: WebKit Reporter: mipohjan <milla.pohjanheimo>
Component: Web Inspector (Deprecated)Assignee: Jocelyn Turcotte <jturcotte>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, jturcotte, keishi, loislo, pfeldman, pmuellr, vsevik, web-inspector-bugs, webkit.review.bot, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 103747    
Attachments:
Description Flags
test application
none
Patch none

Description mipohjan 2013-01-14 03:15:20 PST
In Qt 4.7 if one set the 'always enable' option, the registry keys were created and stored on Windows, but after upgrading to Qt 4.8 the keys don't get created or read anymore.

The javaScript code is in qt/src/3rdparty/webkit/Source/WebCore/inspector/front-end (for Qt 4.8) and the old code (from  Qt 4.7) qt/src/3rdparty/webkit/WebCore/inspector/InspectorController.cpp

The attached application can be used to reproduce the problem.
Comment 1 mipohjan 2013-01-14 03:16:24 PST
Created attachment 182538 [details]
test application
Comment 2 Jocelyn Turcotte 2013-01-17 08:31:15 PST
Created attachment 183194 [details]
Patch

Looked at it and it seems that the settings are persisted differently since http://trac.webkit.org/changeset/76770
An application should call:
QWebSettings::globalSettings()->setLocalStoragePath([PATH]);
QWebSettings::globalSettings()->setAttribute(QWebSettings::LocalStorageEnabled, true);
Or:
QWebSettings::enablePersistentStorage();

to enable those settings to work in the application.
The patch updates the documentation.
Comment 3 WebKit Review Bot 2013-01-21 05:41:34 PST
Comment on attachment 183194 [details]
Patch

Clearing flags on attachment: 183194

Committed r140326: <http://trac.webkit.org/changeset/140326>
Comment 4 WebKit Review Bot 2013-01-21 05:41:37 PST
All reviewed patches have been landed.  Closing bug.