Bug 106050

Summary: REGRESSION(r136152): [WK2] [GTK] Web inspector is not visible
Product: WebKit Reporter: arno. <a.renevier>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia, mrobinson, webkit.review.bot
Priority: P2 Keywords: Regression
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 106052    
Attachments:
Description Flags
patch proposal none

Description arno. 2013-01-03 15:17:19 PST
Hi,

with MiniBrowser, web inspector is not visible.
I launch MiniBrowser (with --enable-developer-extras) flag; I right-click/inspect element.
And I can see that web inspector is active, because I can select an element, and its layout overlay appears. But inspector widget is not attached to the page.
That happens because inspector widget is not registered as inspectorView of the webViewBase.
So, it would be better to call webkitWebViewBaseAddWebInspector instead of just gtk_container_add
Additionaly, it is better to call gtk_container_add instead of webkitWebViewBaseAddWebInspector when inspector has its own window (because m_inspectorWindow is not a WEBKIT_WEB_VIEW_BASE).
Comment 1 arno. 2013-01-03 15:21:05 PST
Created attachment 181233 [details]
patch proposal
Comment 2 Carlos Garcia Campos 2013-01-04 01:34:56 PST
Comment on attachment 181233 [details]
patch proposal

Thanks!
Comment 3 WebKit Review Bot 2013-01-10 01:00:24 PST
Comment on attachment 181233 [details]
patch proposal

Clearing flags on attachment: 181233

Committed r139293: <http://trac.webkit.org/changeset/139293>
Comment 4 WebKit Review Bot 2013-01-10 01:00:28 PST
All reviewed patches have been landed.  Closing bug.