Bug 104414

Summary: [EFL][Qt][WK2] Going back to 47-amazing-css3-animation-demos shows nothing or wrong position
Product: WebKit Reporter: Kenneth Rohde Christiansen <kenneth>
Component: WebKit EFLAssignee: Kenneth Rohde Christiansen <kenneth>
Status: RESOLVED FIXED    
Severity: Normal CC: lucas.de.marchi, noam, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
URL: http://webdesignerwall.com/trends/47-amazing-css3-animation-demos
Bug Depends on:    
Bug Blocks: 103105    
Attachments:
Description Flags
Patch none

Description Kenneth Rohde Christiansen 2012-12-07 16:30:24 PST
Going back to http://webdesignerwall.com/trends/47-amazing-css3-animation-demos shows nothing or wrong position

That is until you touch the mouse wheel, then it moves to the right position it was before.
Comment 1 Kenneth Rohde Christiansen 2012-12-11 06:20:08 PST
clicking on the "image hover effect" demo, opens it, but not at (0, 0) position
Comment 2 Kenneth Rohde Christiansen 2012-12-11 06:20:52 PST
Most of the times when you push back it shows (0, 0) position until you scroll where it jumps to the right position
Comment 3 Kenneth Rohde Christiansen 2012-12-11 06:21:44 PST
but opening the morphing cubes and pressing back, doesn't go to (0,0) but a bit above where it should be, it then jumps automatically to the right position
Comment 4 Kenneth Rohde Christiansen 2012-12-19 04:38:39 PST
This seems to be caused by layouting. It returns to the right position but the image up top is not fully loaded, making it seem like the position move when it appears.

When returning further down it sets a position which is not yet possible due to no content being at that place, returning to (0, 0) instead.

This also affects Qt
Comment 5 Kenneth Rohde Christiansen 2012-12-19 04:41:12 PST
Another question is, why are we so slow at rendering/layout out when going back in history in comparison to Chrome
Comment 6 Kenneth Rohde Christiansen 2012-12-19 05:10:20 PST
Created attachment 180140 [details]
Patch
Comment 7 WebKit Review Bot 2012-12-19 05:46:21 PST
Comment on attachment 180140 [details]
Patch

Clearing flags on attachment: 180140

Committed r138149: <http://trac.webkit.org/changeset/138149>
Comment 8 WebKit Review Bot 2012-12-19 05:46:25 PST
All reviewed patches have been landed.  Closing bug.