Bug 103421

Summary: TextTrackList's .onremovetrack is missing from IDL
Product: WebKit Reporter: Antoine Quint <graouts>
Component: MediaAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: b.long, commit-queue, eric.carlson, esprehn+autocc, jer.noble, ojan.autocc, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
URL: http://w3c-test.org/html/tests/submission/Opera/media/interfaces/TextTrackList/onremovetrack.html
Attachments:
Description Flags
Patch none

Description Antoine Quint 2012-11-27 08:38:36 PST
We fail the Opera-submitted test at http://w3c-test.org/html/tests/submission/Opera/media/interfaces/TextTrackList/onremovetrack.html.

The failure is simply caused by our not supporting the "onremovetrack" property on the TextTrackList interface.
Comment 1 Radar WebKit Bug Importer 2012-11-27 08:38:43 PST
<rdar://problem/12758185>
Comment 2 Brendan Long 2013-04-11 10:08:34 PDT
Created attachment 197635 [details]
Patch
Comment 3 Eric Carlson 2013-04-11 10:15:57 PDT
This looks great, thanks. I will wait to mark the patch r+/cq+ until the bots have had their way with it.
Comment 4 Brendan Long 2013-04-11 14:26:04 PDT
I don't know how this change could possibly effect the output of ietestcenter/css3/grid/grid-items-003.htm (mac-wk2's failing test)..
Comment 5 Eric Carlson 2013-04-11 14:39:08 PDT
(In reply to comment #4)
> I don't know how this change could possibly effect the output of ietestcenter/css3/grid/grid-items-003.htm (mac-wk2's failing test)..

It is unrelated.
Comment 6 WebKit Commit Bot 2013-04-11 16:24:26 PDT
Comment on attachment 197635 [details]
Patch

Clearing flags on attachment: 197635

Committed r148244: <http://trac.webkit.org/changeset/148244>
Comment 7 WebKit Commit Bot 2013-04-11 16:24:28 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Brendan Long 2013-11-22 13:21:51 PST
*** Bug 101347 has been marked as a duplicate of this bug. ***