Bug 10300

Summary: colspan=0 doesn't work
Product: WebKit Reporter: Ian 'Hixie' Hickson <ian>
Component: TablesAssignee: Nobody <webkit-unassigned>
Status: NEW ---    
Severity: Normal CC: arpitabahuguna, bronger, cgriego, jruderman, lascurettes, mathias, mitz, stefan
Priority: P2    
Version: 420+   
Hardware: Macintosh   
OS: OS X 10.4   
Attachments:
Description Flags
test case none

Description Ian 'Hixie' Hickson 2006-08-07 22:38:36 PDT
colspan=0 and rowspan=0 on cells should make them span the entire table. They don't work.
Comment 1 Eric Stith 2007-09-25 16:42:30 PDT
Created attachment 16394 [details]
test case

Compare behavior of webkit vs. Firefox, IE, Opera or W3c standard.  This is an old bug inherited from khtml (http://bugs.kde.org/show_bug.cgi?id=41063).

http://www.w3.org/TR/html4/struct/tables.html#h-11.2.6
Comment 2 Eric Stith 2007-09-25 16:45:08 PDT
This is an old bug inheritted from khtml, where it also remains unfixed and mostly unacknowledged:

http://bugs.kde.org/show_bug.cgi?id=41063
Comment 3 stefan 2011-07-02 03:01:42 PDT
any update on this issue? found it is still in the current nightly build.

br

Stefan
Comment 4 Torsten Bronger 2011-08-08 04:47:02 PDT
It is fixed in KHTML for two years.  I don't know whether both codebases are still similar enough so that this helps, though.
Comment 5 John Lascurettes 2011-08-24 12:58:26 PDT
In addition to the test case attached, the bug can be seen in action on the example link here: http://csswizardry.com/2011/08/two-titillating-table-tips/