Bug 102881

Summary: [V8] Rename v8/custom/*Constructor.cpp to v8/custom/*Custom.cpp
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, gyuyoung.kim, japhet, rakuco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Kentaro Hara
Reported 2012-11-20 22:32:50 PST
Writing constructorCallback()s in *Custom.cpp is a convention of custom bindings of JSC and V8. We can rename v8/custom/*Constructor.cpp to v8/custom/*Custom.cpp.
Attachments
Patch (39.82 KB, patch)
2012-11-20 22:35 PST, Kentaro Hara
no flags
Patch (24.65 KB, patch)
2012-11-21 01:58 PST, Kentaro Hara
no flags
Kentaro Hara
Comment 1 2012-11-20 22:35:54 PST
Kentaro Hara
Comment 2 2012-11-20 22:41:51 PST
Comment on attachment 175343 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=175343&action=review > Source/WebCore/bindings/v8/custom/V8HTMLImageElementCustom.cpp:80 > + int width; > + int height; > + int* optionalWidth = 0; > + int* optionalHeight = 0; > + if (args.Length() > 0) { > + width = toInt32(args[0]); > + optionalWidth = &width; > + } > + if (args.Length() > 1) { > + height = toInt32(args[1]); > + optionalHeight = &height; > + } > + > + RefPtr<HTMLImageElement> image = HTMLImageElement::createForJSConstructor(document, optionalWidth, optionalHeight); This weird logic prevents me from killing HTMLImageElement's custom constructor... We need to distinguish 'new Image()' from 'new Image(null, null)' and 'new Image(undefined, undefined)'. Maybe we need to support overloaded constructors for NamedConstructor, which would be over-engineering.
Adam Barth
Comment 3 2012-11-21 00:24:41 PST
Comment on attachment 175343 [details] Patch ok
WebKit Review Bot
Comment 4 2012-11-21 01:07:39 PST
Comment on attachment 175343 [details] Patch Clearing flags on attachment: 175343 Committed r135358: <http://trac.webkit.org/changeset/135358>
WebKit Review Bot
Comment 5 2012-11-21 01:07:45 PST
All reviewed patches have been landed. Closing bug.
Kentaro Hara
Comment 6 2012-11-21 01:26:48 PST
Reverted r135358 for reason: It broke Chromium/Linux build Committed r135361: <http://trac.webkit.org/changeset/135361>
Kentaro Hara
Comment 7 2012-11-21 01:58:13 PST
WebKit Review Bot
Comment 8 2012-11-21 02:24:52 PST
Comment on attachment 175382 [details] Patch Clearing flags on attachment: 175382 Committed r135368: <http://trac.webkit.org/changeset/135368>
WebKit Review Bot
Comment 9 2012-11-21 02:24:57 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.