Bug 101347

Summary: track element removal should fire 'removetrack' event
Product: WebKit Reporter: Eric Carlson <eric.carlson>
Component: MediaAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: b.long, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Eric Carlson 2012-11-06 07:26:57 PST
When a track element's parent element changes and the old parent was a media element, then the user agent must remove the track element's corresponding text track from the media element's list of text tracks, and then queue a task to fire an event with the name removetrack, that does not bubble and is not cancelable, and that uses the TrackEvent interface, with the track attribute initialized to the text track's TextTrack object, at the media element's textTracks attribute's TextTrackList object.

http://dev.w3.org/html5/spec/media-elements.html#sourcing-out-of-band-text-tracks
Comment 1 Radar WebKit Bug Importer 2012-11-06 07:27:12 PST
<rdar://problem/12644119>
Comment 2 Brendan Long 2013-11-22 13:21:51 PST

*** This bug has been marked as a duplicate of bug 103421 ***