Bug 100568

Summary: Safari 6 (Desktop) crashes when a transition is happening on an element with a calculated width.
Product: WebKit Reporter: userxmx
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WORKSFORME    
Severity: Major CC: ap
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: OS X 10.8   
URL: http://code.metager.de/source/xref/WebKit/LayoutTests/css3/calc/transition-crash.html

Description userxmx 2012-10-26 15:50:04 PDT
Overview : 
Safari 6 crashes when a transition is happening on an element with a calculated width. It happens quicker if you are using sibling selectors with these elements, as well. Not sure if this helps, but the error report says it's WebProcess 4393 in /System/Library/PrivateFrameworks/WebKit2.framework/WebProcess.app/Contents/MacOS/WebProcess, version 8536.25 and then shows some issues regarding WebCore::Length::incrementCalculatedRef(), WebCore::RenderStyle::setWidth, WebCore::CSSPropertyAnimation::blendProperties, WebCore::AnimationController::updateAnimations and WebCore::Element::recalcStyle, among others.

Steps to Reproduce:
See URL (http://code.metager.de/source/xref/WebKit/LayoutTests/css3/calc/transition-crash.html) and subsequent crash test pages to see examples of code that will trigger it. I ran into this issue initially using jQuery animate in conjunction with previously established transitions across all anchors. After removing the transition effects on these specific elements, the browser only crashes when the elements are hovered over. Same problem after the jQuery-set animations were removed.

Actual Results:
Browser crashes. After repeated attempts, the OS ended up freezing entirely.

Expected Results:
Should be able to animate these calculated-width elements like previous version of Safari. 

Build Date & Platform:
Safari 6 on Mac OS 10.8

Additional Builds & Platforms:
Works as intended in Chrome and Firefox. Haven't tested Safari on Windows at all.

Additional Information:
I ended up crashing the entire OS I was remoting into to test this and won't be able to get back to it until Monday, so I don't have a crash log available at the moment, but I have what I believe are the relevant threads listed in the Overview.
Comment 1 Alexey Proskuryakov 2012-10-29 10:31:23 PDT
<rdar://problem/12388256>
Comment 2 Alexey Proskuryakov 2012-10-29 10:32:24 PDT
This crashes Safari 6.0.1, but not nightlies, seems fixed.