Bug 105694

Summary: [chromium] Bottom part of non-square glyphs in upright are cut off in vertical flow
Product: WebKit Reporter: Koji Ishii <kojiishi>
Component: Layout and RenderingAssignee: takao
Status: RESOLVED FIXED    
Severity: Normal CC: dominicc, efidler, syoichi, takao, xz911jp
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows 7   
Attachments:
Description Flags
Test flie: the bottom part is cut off in some glyphs in vertical flow
none
Test file current result none

Description Koji Ishii 2012-12-23 11:09:54 PST
When writing-mode:vertical-rl; text-orientation:upright is specified, and when system fallback font is used or self/sanserif is used, font advance is incorrect, and characters overlaps each other.
Comment 1 Koji Ishii 2013-01-13 22:46:24 PST
Created attachment 182510 [details]
Test flie: the bottom part is cut off in some glyphs in vertical flow
Comment 2 Koji Ishii 2013-01-13 22:49:33 PST
Created attachment 182511 [details]
Test file current result
Comment 3 Koji Ishii 2013-01-13 22:55:23 PST
As I created a test file, I found the issue assessment was incorrect.

The issue is, when non-square glyphs are drawn, the bottom part of glyphs are cut off in certain size. Please see the attached test file and the current result image.

As far as I tested, this issue occurs with MS PGothic 12pt and 14pt. Setting to different size, or using MS Gothic (which all of its glyphs are square) solve the issue.

The bad part is that, MS PGothic is the default Japanese font, Chromium automatically choose it for sans-serif, and 12pt and 14pt are pretty common use cases.
Comment 4 Koji Ishii 2013-01-14 00:56:53 PST
Another test example is at http://epub.nomaki.jp/121217/test-006.html
Comment 5 takao 2013-01-17 20:26:13 PST
I will work for fixing this bug.
Could you assign to me?
Comment 6 takao 2013-02-25 04:32:11 PST
I found out what's wrong is skia, not WebKit.

The bug can be fixed by modifying skia code,
should I report detail to skia group rather than here?
Comment 7 takao 2013-02-28 21:57:31 PST
I reported to skia group:
Issue 1138 - skia - Some TTF embedded bitmaps are drawn incompletely
https://code.google.com/p/skia/issues/detail?id=1138
Comment 8 takao 2013-03-05 20:46:31 PST
(In reply to comment #4)
> Another test example is at http://epub.nomaki.jp/121217/test-006.html

It does not seems same as the original matter.
Should be managed on new report.
Comment 9 takao 2013-03-11 20:05:37 PDT
skia has been fixed in r8069.
https://code.google.com/p/skia/source/detail?r=8069

Chromium DEPS will be updated shortly.